kernel: remove obsolete kernel version switches for 4.14
[openwrt/staging/hauke.git] / package / kernel / linux / modules / fs.mk
index 84dc498365dbefea6f733c08634674e6d3371d84..9b3a6dce46fbeab3ac831a51b70057c985eb78a8 100644 (file)
@@ -53,8 +53,7 @@ define KernelPackage/fs-autofs4
        CONFIG_AUTOFS4_FS \
        CONFIG_AUTOFS_FS
   FILES:= \
-       $(LINUX_DIR)/fs/autofs4/autofs4.ko@lt4.18 \
-       $(LINUX_DIR)/fs/autofs/autofs4.ko@ge4.18
+       $(LINUX_DIR)/fs/autofs/autofs4.ko
   AUTOLOAD:=$(call AutoLoad,30,autofs4)
 endef
 
@@ -206,7 +205,7 @@ $(eval $(call KernelPackage,fs-ext4))
 define KernelPackage/fs-f2fs
   SUBMENU:=$(FS_MENU)
   TITLE:=F2FS filesystem support
-  DEPENDS:= +kmod-crypto-hash +kmod-crypto-crc32 +LINUX_5_4:kmod-nls-base
+  DEPENDS:= +kmod-crypto-hash +kmod-crypto-crc32 +!LINUX_4_19:kmod-nls-base
   KCONFIG:= \
        CONFIG_F2FS_FS \
        CONFIG_F2FS_STAT_FS=y \