build: replace which with Bash command built-in
[openwrt/staging/hauke.git] / include / prereq.mk
index 83ac21242c6535b9bdd03e70b2b91f10161231e5..6d14140792f370b8909af6f617c6fa489480f9da 100644 (file)
@@ -52,7 +52,7 @@ endef
 
 define RequireCommand
   define Require/$(1)
-    which $(1)
+    command -pv $(1)
   endef
 
   $$(eval $$(call Require,$(1),$(2)))
@@ -106,7 +106,7 @@ define SetupHostCommand
                   $(call QuoteHostCommand,$(11)) $(call QuoteHostCommand,$(12)); do \
                if [ -n "$$$$$$$$cmd" ]; then \
                        bin="$$$$$$$$(PATH="$(subst $(space),:,$(filter-out $(STAGING_DIR_HOST)/%,$(subst :,$(space),$(PATH))))" \
-                               which "$$$$$$$${cmd%% *}")"; \
+                               command -pv "$$$$$$$${cmd%% *}")"; \
                        if [ -x "$$$$$$$$bin" ] && eval "$$$$$$$$cmd" >/dev/null 2>/dev/null; then \
                                mkdir -p "$(STAGING_DIR_HOST)/bin"; \
                                ln -sf "$$$$$$$$bin" "$(STAGING_DIR_HOST)/bin/$(strip $(1))"; \