x86: Add kmod-dwmac-intel
[openwrt/staging/hauke.git] / include / prereq.mk
index c888268d852074859bd9844171b7d75adc5d521a..1039c5540c6a01a17d61851a7aa2f334d8eb1df4 100644 (file)
@@ -107,11 +107,9 @@ define SetupHostCommand
                        bin="$$$$$$$$(command -v "$$$$$$$${cmd%% *}")"; \
                        if [ -x "$$$$$$$$bin" ] && eval "$$$$$$$$cmd" >/dev/null 2>/dev/null; then \
                                case "$$$$$$$$(ls -dl -- $(STAGING_DIR_HOST)/bin/$(strip $(1)))" in \
-                                       *" -> $$$$$$$$bin"*) \
-                                               [ -x "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0 \
-                                               ;; \
-                                       "-"*) \
-                                               find "$(STAGING_DIR_HOST)/stamp" | grep $(strip $(1)) && \
+                                       "-"* | \
+                                       *" -> $$$$$$$$bin"* | \
+                                       *" -> "[!/]*) \
                                                [ -x "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0 \
                                                ;; \
                                esac; \