build: introduce extra targets that contain only proper dependencies
[openwrt/staging/hauke.git] / include / package-ipkg.mk
index e168eb390f31290c68ecb406b09339d69fc9495b..8727b4ec30213141fb8875d2850679b43373e266 100644 (file)
@@ -106,9 +106,9 @@ ifeq ($(DUMP),)
     ifdef do_install
       ifneq ($(CONFIG_PACKAGE_$(1))$(DEVELOPER),)
         IPKGS += $(1)
-        compile: $$(IPKG_$(1)) $(PKG_INFO_DIR)/$(1).provides $(STAGING_DIR_ROOT)/stamp/.$(1)_installed
+        .compile: $$(IPKG_$(1)) $(PKG_INFO_DIR)/$(1).provides $(STAGING_DIR_ROOT)/stamp/.$(1)_installed
         ifneq ($(ABI_VERSION),)
-        compile: $(PKG_INFO_DIR)/$(1).version
+        .compile: $(PKG_INFO_DIR)/$(1).version
         endif
       else
         $(if $(CONFIG_PACKAGE_$(1)),$$(info WARNING: skipping $(1) -- package not selected))