x86: Add kmod-dwmac-intel
[openwrt/staging/hauke.git] / include / depends.mk
index ace7139000db1d21359b54159e9ffbbfb3d5615a..a858d4b033eb47e7b83564d578f78596914b79ce 100644 (file)
@@ -1,9 +1,7 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# Copyright (C) 2007-2020 OpenWrt.org
+
 # define a dependency on a subtree
 # parameters:
 #      1: directories/files
@@ -13,7 +11,8 @@
 
 DEP_FINDPARAMS := -x "*/.svn*" -x ".*" -x "*:*" -x "*\!*" -x "* *" -x "*\\\#*" -x "*/.*_check" -x "*/.*.swp" -x "*/.pkgdir*"
 
-find_md5=find $(wildcard $(1)) -type f $(patsubst -x,-and -not -path,$(DEP_FINDPARAMS) $(2)) -printf "%p%T@\n" | sort | mkhash md5
+find_md5=find $(wildcard $(1)) -type f $(patsubst -x,-and -not -path,$(DEP_FINDPARAMS) $(2)) -printf "%p%T@\n" | sort | $(MKHASH) md5
+find_md5_reproducible=find $(wildcard $(1)) -type f $(patsubst -x,-and -not -path,$(DEP_FINDPARAMS) $(2)) -print0 | xargs -0 $(MKHASH) md5 | sort | $(MKHASH) md5
 
 define rdep
   .PRECIOUS: $(2)
@@ -29,7 +28,7 @@ ifneq ($(wildcard $(2)),)
                { [ \! -f "$(3)" ] || diff $(3) $(3).1 >/dev/null; } && \
        ) \
        { \
-               [ -f "$(2)_check.1" ] && mv "$(2)_check.1"; \
+               [ -f "$(2)_check.1" ] && mv "$(2)_check.1" "$(2)_check"; \
            $(TOPDIR)/scripts/timestamp.pl $(DEP_FINDPARAMS) $(4) -n $(2) $(1) && { \
                        $(call debug_eval,$(SUBDIR),r,echo "No need to rebuild $(2)";) \
                        touch -r "$(2)" "$(2)_check"; \