ramips: rename Digineo AC1200 Pro to ZBT-WG3526 32MB
[openwrt/staging/florian.git] / target / linux / ramips / image / mt7621.mk
index ae5bf5e1738f8bcabb92a2d98bbed9c1a0effdbc..b57552a6f4c35cf5f98d8dbf2315e956fd31e96f 100644 (file)
@@ -34,14 +34,6 @@ define Device/11acnas
 endef
 TARGET_DEVICES += 11acnas
 
-define Device/ac1200pro
-  DTS := AC1200pro
-  IMAGE_SIZE := $(ralink_default_fw_size_32M)
-  DEVICE_TITLE := Digineo AC1200 Pro
-  DEVICE_PACKAGES := kmod-usb3 kmod-ata-core kmod-ata-ahci
-endef
-TARGET_DEVICES += ac1200pro
-
 define Device/dir-860l-b1
   DTS := DIR-860L-B1
   BLOCKSIZE := 64k
@@ -270,6 +262,15 @@ define Device/zbt-wg3526-16M
 endef
 TARGET_DEVICES += zbt-wg3526-16M
 
+define Device/zbt-wg3526-32M
+  DTS := ZBT-WG3526-32M
+  IMAGE_SIZE := $(ralink_default_fw_size_32M)
+  SUPPORTED_DEVICES += ac1200pro
+  DEVICE_TITLE := ZBT WG3526 (32MB flash)
+  DEVICE_PACKAGES := kmod-usb3 kmod-usb-ledtrig-usbport kmod-ata-core kmod-ata-ahci kmod-sdhci-mt7620
+endef
+TARGET_DEVICES += zbt-wg3526-32M
+
 # FIXME: is this still needed?
 define Image/Prepare
 #define Build/Compile