ramips: purge default packages on MT7621
[openwrt/staging/florian.git] / target / linux / ramips / Makefile
index a12751290188f225f8df805b2fbd2e3aedeaca93..1de220e1a30477c3ba7d8a4998756b68e307d040 100644 (file)
@@ -8,19 +8,19 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=ramips
-BOARDNAME:=Ralink RT288x/RT3xxx
-SUBTARGETS:=rt305x rt3883 mt7620a rt288x
+BOARDNAME:=MediaTek Ralink MIPS
+SUBTARGETS:=rt305x mt7620 mt7621 mt7628 mt7688 rt3883 rt288x
 FEATURES:=squashfs gpio
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=3.10.18
-
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=\
-       kmod-leds-gpio kmod-gpio-button-hotplug \
-       kmod-rt2800-pci wpad-mini swconfig
+KERNEL_PATCHVER:=4.4
 
 define Target/Description
        Build firmware images for Ralink RT288x/RT3xxx based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+       kmod-leds-gpio kmod-gpio-button-hotplug swconfig
+
 $(eval $(call BuildTarget))