omap: Add support for kernel 4.9
[openwrt/staging/dedeckeh.git] / target / linux / omap / Makefile
index 91b9d9b20a2c4c1018465e83bbb47eb3ed69185b..d8c0fd88e94b86bce0e6337479f750837d2d395a 100644 (file)
@@ -4,16 +4,17 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=omap
 BOARDNAME:=TI OMAP3/4/AM33xx
 FEATURES:=usb usbgadget ext4 targz fpu audio display nand ubifs
-CPU_TYPE:=cortex-a9
+CPU_TYPE:=cortex-a8
 CPU_SUBTYPE:=vfpv3
 
-KERNEL_PATCHVER:=4.4
+KERNEL_PATCHVER:=4.9
 
 MAINTAINER:=Alexander Couzens <lynxis@fe80.eu>
 
@@ -25,6 +26,4 @@ endef
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
-
 $(eval $(call BuildTarget))