omap: Add support for kernel 4.9
[openwrt/staging/dedeckeh.git] / target / linux / omap / Makefile
index 78361fc3032a64c13bc10085e8f1c2023e0d34c8..d8c0fd88e94b86bce0e6337479f750837d2d395a 100644 (file)
@@ -1,27 +1,24 @@
 #
-# Copyright (C) 2012-2013 OpenWrt.org
+# Copyright (C) 2012-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=omap
 BOARDNAME:=TI OMAP3/4/AM33xx
-FEATURES:=usb targz audio display
-CPU_TYPE:=cortex-a9
+FEATURES:=usb usbgadget ext4 targz fpu audio display nand ubifs
+CPU_TYPE:=cortex-a8
 CPU_SUBTYPE:=vfpv3
 
-LINUX_VERSION:=3.12
-
-MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-
-KERNELNAME:="zImage dtbs"
+KERNEL_PATCHVER:=4.9
 
-DEFAULT_PACKAGES += uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
+MAINTAINER:=Alexander Couzens <lynxis@fe80.eu>
 
-DEVICE_TYPE=developerboard
+KERNELNAME:=zImage dtbs
 
 define Target/Description
        TI OMAP boards