at91bootstrap:update to v3.8.10
[openwrt/staging/dedeckeh.git] / package / boot / at91bootstrap / Makefile
index ae60fad445aac801a1ad927da8cb627661eb6296..8a1ec5e9c917cb79ad5529c0e4ec42434525d6bf 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=at91bootstrap
-PKG_VERSION:=v3.8.8
+PKG_VERSION:=v3.8.10
 PKG_RELEASE:=
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/linux4sam/at91bootstrap.git
-PKG_SOURCE_VERSION:=3d33a4e0707c61007a5278f6620453502f7500db
+PKG_SOURCE_VERSION:=04efa5500d60a0211d14b6ee60df7ce0a828704d
 
 PKG_BUILD_DIR = \
     $(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
@@ -24,54 +24,48 @@ include $(INCLUDE_DIR)/package.mk
 
 define AT91Bootstrap/Default
   BUILD_TARGET:=at91
+  BUILD_SUBTARGET:=sama5
+  HIDDEN:=1
   AT91BOOTSTRAP_IMAGE:=at91bootstrap.bin
 endef
 
-define at91bootstrap/sama5d2_xplaineddf_uboot
-  TITLE:=AT91Bootstrap for the SAMA5D3 Xplained board (SPI Flash)
-  BUILD_SUBTARGET:=sama5
-  BUILD_DEVICES:=at91-sama5d3_xplained
+define AT91Bootstrap/sama5d2_xplaineddf_uboot
+  TITLE:=AT91Bootstrap for SAMA5D2 Xplained board (SPI Flash)
+  BUILD_DEVICES:=at91-sama5d2_xplained
 endef
 
-define at91bootstrap/sama5d2_xplaineddf_qspi_uboot
-  TITLE:=AT91Bootstrap for the SAMA5D2 Xplained board (QSPI Flash)
-  BUILD_SUBTARGET:=sama5
+define AT91Bootstrap/sama5d2_xplaineddf_qspi_uboot
+  TITLE:=AT91Bootstrap for SAMA5D2 Xplained board (QSPI Flash)
   BUILD_DEVICES:=at91-sama5d2_xplained
 endef
 
-define at91bootstrap/sama5d2_xplainedsd_uboot
-  TITLE:=AT91Bootstrap for the SAMA5D2 Xplained board (SDcard/EMMC)
-  BUILD_SUBTARGET:=sama5
+define AT91Bootstrap/sama5d2_xplainedsd_uboot
+  TITLE:=AT91Bootstrap for SAMA5D2 Xplained board (SDcard/EMMC)
   BUILD_DEVICES:=at91-sama5d2_xplained
 endef
 
-define at91bootstrap/sama5d3_xplainednf_uboot
-  TITLE:=AT91Bootstrap for the SAMA5D3 Xplained board (Nand Flash)
-  BUILD_SUBTARGET:=sama5
+define AT91Bootstrap/sama5d3_xplainednf_uboot
+  TITLE:=AT91Bootstrap for SAMA5D3 Xplained board (Nand Flash)
   BUILD_DEVICES:=at91-sama5d3_xplained
 endef
 
-define at91bootstrap/sama5d3_xplainedsd_uboot
-  TITLE:=AT91Bootstrap for the SAMA5D3 Xplained board (SDcard)
-  BUILD_SUBTARGET:=sama5
+define AT91Bootstrap/sama5d3_xplainedsd_uboot
+  TITLE:=AT91Bootstrap for SAMA5D3 Xplained board (SDcard)
   BUILD_DEVICES:=at91-sama5d3_xplained
 endef
 
-define at91bootstrap/sama5d4_xplainednf_uboot
-  TITLE:=AT91Bootstrap for the SAMA5D4 Xplained board (Nand Flash)
-  BUILD_SUBTARGET:=sama5
+define AT91Bootstrap/sama5d4_xplainednf_uboot_secure
+  TITLE:=AT91Bootstrap for SAMA5D4 Xplained board (Nand Flash)
   BUILD_DEVICES:=at91-sama5d4_xplained
 endef
 
-define at91bootstrap/sama5d4_xplaineddf_uboot_secure
-  TITLE:=AT91Bootstrap for the SAMA5D4 Xplained board (SPI Flash)
-  BUILD_SUBTARGET:=sama5
+define AT91Bootstrap/sama5d4_xplaineddf_uboot_secure
+  TITLE:=AT91Bootstrap for SAMA5D4 Xplained board (SPI Flash)
   BUILD_DEVICES:=at91-sama5d4_xplained
 endef
 
-define at91bootstrap/sama5d4_xplainedsd_uboot_secure
-  TITLE:=AT91Bootstrap for the SAMA5D4 Xplained board (SDcard)
-  BUILD_SUBTARGET:=sama5
+define AT91Bootstrap/sama5d4_xplainedsd_uboot_secure
+  TITLE:=AT91Bootstrap for SAMA5D4 Xplained board (SDcard)
   BUILD_DEVICES:=at91-sama5d4_xplained
 endef