tools/patchelf: update to 0.18.0
[openwrt/staging/dedeckeh.git] / include / rootfs.mk
index a3a08c2851cd0a377e36284c69e1518e94b694cc..f2ed648d2f3eb51a31115d4d3d22dc4982959d97 100644 (file)
@@ -1,5 +1,3 @@
-include $(INCLUDE_DIR)/feeds.mk
-
 ifdef CONFIG_USE_MKLIBS
   define mklibs
        rm -rf $(TMP_DIR)/mklibs-progs $(TMP_DIR)/mklibs-out
@@ -49,7 +47,7 @@ TARGET_DIR_ORIG := $(TARGET_ROOTFS_DIR)/root.orig-$(BOARD)
 
 ifdef CONFIG_CLEAN_IPKG
   define clean_ipkg
-       -find $(1)/usr/lib/opkg/info -type f -and -not -name '*.control' | $(XARGS) rm -rf
+       -find $(1)/usr/lib/opkg/info -type f -and -not -name '*.control' -delete
        -sed -i -ne '/^Require-User: /p' $(1)/usr/lib/opkg/info/*.control
        awk ' \
                BEGIN { conffiles = 0; print "Conffiles:" } \
@@ -58,20 +56,20 @@ ifdef CONFIG_CLEAN_IPKG
                conffiles == 1 { print } \
        ' $(1)/usr/lib/opkg/status >$(1)/usr/lib/opkg/status.new
        mv $(1)/usr/lib/opkg/status.new $(1)/usr/lib/opkg/status
-       -find $(1)/usr/lib/opkg -empty | $(XARGS) rm -rf
+       -find $(1)/usr/lib/opkg -empty -delete
   endef
 endif
 
 define prepare_rootfs
-       @if [ -d $(TOPDIR)/files ]; then \
-               $(call file_copy,$(TOPDIR)/files/.,$(1)); \
-       fi
+       $(if $(2),@if [ -d '$(2)' ]; then \
+               $(call file_copy,$(2)/.,$(1)); \
+       fi)
        @mkdir -p $(1)/etc/rc.d
        @mkdir -p $(1)/var/lock
        @( \
                cd $(1); \
                for script in ./usr/lib/opkg/info/*.postinst; do \
-                       IPKG_INSTROOT=$(1) $$(which bash) $$script; \
+                       IPKG_INSTROOT=$(1) $$(command -v bash) $$script; \
                        ret=$$?; \
                        if [ $$ret -ne 0 ]; then \
                                echo "postinst script $$script has failed with exit code $$ret" >&2; \
@@ -80,18 +78,24 @@ define prepare_rootfs
                done; \
                for script in ./etc/init.d/*; do \
                        grep '#!/bin/sh /etc/rc.common' $$script >/dev/null || continue; \
-                       IPKG_INSTROOT=$(1) $$(which bash) ./etc/rc.common $$script enable; \
+                       if ! echo " $(3) " | grep -q " $$(basename $$script) "; then \
+                               IPKG_INSTROOT=$(1) $$(command -v bash) ./etc/rc.common $$script enable; \
+                               echo "Enabling" $$(basename $$script); \
+                       else \
+                               IPKG_INSTROOT=$(1) $$(command -v bash) ./etc/rc.common $$script disable; \
+                               echo "Disabling" $$(basename $$script); \
+                       fi; \
                done || true \
        )
        $(if $(SOURCE_DATE_EPOCH),sed -i "s/Installed-Time: .*/Installed-Time: $(SOURCE_DATE_EPOCH)/" $(1)/usr/lib/opkg/status)
-       @-find $(1) -name CVS   | $(XARGS) rm -rf
-       @-find $(1) -name .svn  | $(XARGS) rm -rf
-       @-find $(1) -name .git  | $(XARGS) rm -rf
-       @-find $(1) -name '.#*' | $(XARGS) rm -f
-       rm -rf $(1)/tmp/*
-       rm -f $(1)/usr/lib/opkg/lists/*
-       rm -f $(1)/usr/lib/opkg/info/*.postinst*
-       rm -f $(1)/var/lock/*.lock
+       @-find $(1) -name CVS -o -name .svn -o -name .git -o -name '.#*' | $(XARGS) rm -rf
+       rm -rf \
+               $(1)/boot \
+               $(1)/tmp/* \
+               $(1)/usr/lib/opkg/info/*.postinst* \
+               $(1)/usr/lib/opkg/lists/* \
+               $(1)/var/lock/*.lock
        $(call clean_ipkg,$(1))
        $(call mklibs,$(1))
+       $(if $(SOURCE_DATE_EPOCH),find $(1)/ -mindepth 1 -execdir touch -hcd "@$(SOURCE_DATE_EPOCH)" "{}" +)
 endef