kirkwood: clean up profiles, move to image makefile
[openwrt/staging/blogic.git] / target / linux / kirkwood / image / Makefile
index 383689d469544f024c6e6044bdae2f4d0e170e2f..2c4ad208f2740c3c54a406c27a88a896e1506495 100644 (file)
@@ -17,6 +17,7 @@ UBI_OPTS := -m 2048 -p 128KiB -s 512
 UBIFS_OPTS := -m 2048 -e 126KiB -c 4096
 
 define Device/Default
+  PROFILES := Default
   KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
   KERNEL := kernel-bin | append-dtb | uImage none
   KERNEL_NAME := zImage
@@ -34,7 +35,7 @@ endef
 define Device/dockstar
   DEVICE_DTS := kirkwood-dockstar
   FILESYSTEMS := squashfs
-  PROFILES := Generic DOCKSTAR
+  DEVICE_TITLE := Seagate FreeAgent Dockstar
   IMAGES += factory.bin
   IMAGE/factory.bin := append-ubi
   KERNEL_IN_UBI := 1
@@ -42,49 +43,51 @@ endef
 
 define Device/goflexnet
 $(Device/dockstar)
-  PROFILES := Generic GOFLEXNET
+  DEVICE_TITLE := Seagate GoFlexNet
   DEVICE_DTS := kirkwood-goflexnet
 endef
 
 define Device/goflexhome
 $(Device/dockstar)
-  PROFILES := Generic GOFLEXHOME
+  DEVICE_TITLE := Seagate GoFlexHome
   DEVICE_DTS := kirkwood-goflexhome
 endef
 
 define Device/linksys-audi
+  DEVICE_TITLE := Linksys EA3500 (Audi)
+  DEVICE_PACKAGES := kmod-mwl8k swconfig wpad-mini
   DEVICE_DTS := kirkwood-linksys-audi
   KERNEL_SIZE := 2624k
   FILESYSTEMS := squashfs
-  PROFILES := Generic AUDI
   IMAGES += factory.bin
   IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
 endef
 
 define Device/linksys-viper
+  DEVICE_TITLE := Linksys E4200v2 / EA4500 (Viper)
+  DEVICE_PACKAGES := kmod-mwl8k swconfig wpad-mini
   DEVICE_DTS := kirkwood-linksys-viper
   KERNEL_SIZE := 2688k
   FILESYSTEMS := squashfs
-  PROFILES := Generic VIPER
   IMAGES += factory.bin
   IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
 endef
 
 define Device/iconnect
 $(Device/dockstar)
-  PROFILES := Generic ICONNECT
+  DEVICE_TITLE := Iomega Iconnect
   DEVICE_DTS := kirkwood-iconnect
 endef
 
 define Device/pogo_e02
 $(Device/dockstar)
-  PROFILES := Generic POGOE02
+  DEVICE_TITLE := Cloud Engines Pogoplug E02
   DEVICE_DTS := kirkwood-pogo_e02
 endef
 
 define Device/ib62x0
 $(Device/dockstar)
-  PROFILES := Generic IB62X0
+  DEVICE_TITLE := RaidSonic ICY BOX IB-NAS62x0
   DEVICE_DTS := kirkwood-ib62x0
 endef