kirkwood: clean up FEATURES
[openwrt/staging/blogic.git] / target / linux / kirkwood / Makefile
index 8d2a7c25cc43c7645cdb6331f40ba654900d7c56..53471c637ce1ec17eeb70ca7aa6c2f1f06b2c3ec 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,17 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=kirkwood
 BOARDNAME:=Marvell Kirkwood
-FEATURES:=targz usb jffs2
-MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+FEATURES:=usb nand squashfs
+CPU_TYPE:=xscale
+MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
-LINUX_VERSION:=2.6.35.7
+KERNEL_PATCHVER:=4.4
 
 include $(INCLUDE_DIR)/target.mk
 
-CFLAGS:=-Os -pipe -march=armv5te -mtune=marvell-f -funit-at-a-time
+KERNELNAME:=zImage dtbs
 
-KERNELNAME:="uImage"
-
-DEFAULT_PACKAGES +=
+DEFAULT_PACKAGES += uboot-envtools
 
 $(eval $(call BuildTarget))