cleanup uboot package
[openwrt/staging/blogic.git] / package / uboot-ifxmips / files / cpu / mips / danube / Makefile
index da329b378ec7b71e8c1d3de8c6fc81e35b6c1faa..6f7b5dc68a5d201cba0621c66c41c02285cebf0d 100644 (file)
@@ -1,5 +1,6 @@
+#########################################################################
 #
-# (C) Copyright 2003-2006
+# (C) Copyright 2000-2006
 # Wolfgang Denk, DENX Software Engineering, wd@denx.de.
 #
 # See file CREDITS for list of people who contributed to this
 
 include $(TOPDIR)/config.mk
 
-LIB    = $(obj)lib$(CPU).a
+LIB    = $(obj)lib$(SOC).a
 
-START  = start.o
-COBJS  = asc_serial.o au1x00_serial.o au1x00_eth.o au1x00_usb_ohci.o \
-         cpu.o interrupts.o incaip_clock.o ifx_asc.o ifx_clock.o
-SOBJS  = incaip_wdt.o cache.o
+COBJS  = ifx_asc.o ifx_clock.o
 
-SRCS   := $(START:.o=.S) $(SOBJS:.o=.S) $(COBJS:.o=.c)
+SRCS   := $(SOBJS:.o=.S) $(COBJS:.o=.c)
 OBJS   := $(addprefix $(obj),$(SOBJS) $(COBJS))
-START  := $(addprefix $(obj),$(START))
 
-all:   $(obj).depend $(START) $(LIB)
+all:   $(obj).depend $(LIB)
 
 $(LIB):        $(OBJS)
        $(AR) $(ARFLAGS) $@ $(OBJS)