treewide: clean up and unify PKG_VERSION for git based downloads
[openwrt/staging/blogic.git] / package / network / utils / nftables / Makefile
index 4f25ee91e768a694fe5c7db759f5c0dc17fbfc36..4fdd58265f7fa71e2c486eb8b63d07e54506198c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2014 OpenWrt.org
+# Copyright (C) 2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,14 +7,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nftables
-PKG_VERSION:=0.3+2014-10-21
+PKG_VERSION:=0.4+2015-04-09
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_URL:=git://git.netfilter.org/nftables
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=17b495957b29e699f59874d1ceca9535921b1a79
+PKG_SOURCE_VERSION:=3ed296118a065caff5600e60d4f7ef18e137f9a0
+PKG_MIRROR_HASH:=7f6f6162592c848b8047e75374f01a93d2d269dabe013a0150767027049b1e41
 PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
 PKG_LICENSE:=GPL-2.0
 
@@ -23,8 +22,7 @@ PKG_FIXUP:=autoreconf
 include $(INCLUDE_DIR)/package.mk
 
 CONFIGURE_ARGS += \
-        --disable-debug \
-        --without-libgmp \
+        --with-mini-gmp \
         --without-cli \
 
 define Package/nftables