gettext-full: enforce only static lib on the host build
[openwrt/staging/blogic.git] / package / libs / gettext-full / Makefile
index 2ae8cd3827a6e583fc8be3c9fa704cd083db3f2e..64d27609c3d35254efb46df71882a6e474521452 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,16 +8,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gettext-full
-PKG_VERSION:=0.18.1.1
-PKG_RELEASE:=2
+PKG_VERSION:=0.19.8.1
+PKG_RELEASE:=1
 
-PKG_SOURCE:=gettext-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=gettext-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gettext
-PKG_MD5SUM:=3dd55b952826d2b32f51308f2f91aa89
+PKG_HASH:=105556dbc5c3fbbc2aa0edb46d22d055748b6f5c7cd7a8d99f8e7eb84e938be4
 PKG_BUILD_DIR:=$(BUILD_DIR)/gettext-$(PKG_VERSION)
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/gettext-$(PKG_VERSION)
 
-PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
+PKG_LICENSE:=GPL-3.0+
 
 PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
@@ -35,20 +36,43 @@ define Package/libintl-full
 endef
 
 TARGET_CFLAGS += $(FPIC)
+ifneq ($(HOST_OS),Linux)
+  TARGET_CFLAGS += -I$(STAGING_DIR)/host/include
+endif
+ifdef CONFIG_USE_MUSL
+  TARGET_CFLAGS += -D__UCLIBC__
+endif
 
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
+       --disable-libasprintf \
        --disable-rpath \
        --enable-nls \
        --disable-java \
        --disable-native-java \
        --disable-openmp \
+       --disable-curses \
        --with-included-gettext \
        --without-libintl-prefix \
        --without-libexpat-prefix \
        --without-emacs
 
+HOST_CONFIGURE_ARGS += \
+       --disable-shared \
+       --enable-static \
+       --disable-libasprintf \
+       --disable-rpath \
+       --disable-java \
+       --disable-native-java \
+       --disable-openmp \
+       --without-emacs \
+       --without-libxml2-prefix
+
+
+HOST_CONFIGURE_VARS += \
+       EMACS="no"
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/lib/libintl-full/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/libintl.h $(1)/usr/lib/libintl-full/include/
@@ -58,6 +82,8 @@ define Build/InstallDev
 
        $(INSTALL_DIR) $(1)/usr/share/aclocal
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/aclocal/* $(1)/usr/share/aclocal/
+
+       $(SED) '/read dummy/d' $(STAGING_DIR)/host/bin/gettextize
 endef
 
 define Package/libintl-full/install