ath10k-ct: Enable DFS when "Enable DFS support" is set for kmod-ath
[openwrt/staging/blogic.git] / package / kernel / ath10k-ct / Makefile
index c5e504512481576341fb60ced349cf5e32ece767..97f284efbfd0f614f96c303334546732f98da0b2 100644 (file)
@@ -61,6 +61,10 @@ ifdef CONFIG_PACKAGE_ATH_DEBUG
   NOSTDINC_FLAGS += -DCONFIG_ATH10K_DEBUG
 endif
 
+ifdef CONFIG_PACKAGE_ATH_DFS
+  NOSTDINC_FLAGS += -DCONFIG_ATH10K_DFS_CERTIFIED
+endif
+
 define Build/Configure
        cp $(STAGING_DIR)/usr/include/mac80211/ath/*.h $(PKG_BUILD_DIR)
 endef