ar71xx: increase kernel partition size for some TP-Link boards
authorHenryk Heisig <hyniu@o2.pl>
Thu, 26 Oct 2017 22:23:17 +0000 (00:23 +0200)
committerPiotr Dymacz <pepe2k@gmail.com>
Tue, 14 Nov 2017 21:36:46 +0000 (22:36 +0100)
This patch increases kernel partition size and re-enables image
generation for below TP-Link boards:

- archer-c58-v1
- archer-c60-v1
- tl-wr902ac-v1
- tl-wr942n-v1

Signed-off-by: Henryk Heisig <hyniu@o2.pl>
[commit message and title reworded]
Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
target/linux/ar71xx/image/tp-link.mk
tools/firmware-utils/src/tplink-safeloader.c

index b7689c2741330c14cf9d4dbe87991b2f40e8948c..2dedf3564bfe6554e65487e508e16f240c8063a5 100644 (file)
@@ -123,7 +123,7 @@ define Device/archer-c58-v1
   TPLINK_BOARD_ID := ARCHER-C58-V1
   DEVICE_PROFILE := ARCHERC58V1
   IMAGE_SIZE := 7936k
-  MTDPARTS := spi0.0:64k(u-boot)ro,64k(mac)ro,1344k(kernel),6592k(rootfs),64k(tplink)ro,64k(art)ro,7936k@0x20000(firmware)
+  MTDPARTS := spi0.0:64k(u-boot)ro,64k(mac)ro,7936k(firmware),64k(tplink)ro,64k(art)ro
   SUPPORTED_DEVICES := archer-c58-v1
 endef
 
@@ -147,10 +147,10 @@ define Device/archer-c60-v1
   TPLINK_BOARD_ID := ARCHER-C60-V1
   DEVICE_PROFILE := ARCHERC60V1
   IMAGE_SIZE := 7936k
-  MTDPARTS := spi0.0:64k(u-boot)ro,64k(mac)ro,1344k(kernel),6592k(rootfs),64k(tplink)ro,64k(art)ro,7936k@0x20000(firmware)
+  MTDPARTS := spi0.0:64k(u-boot)ro,64k(mac)ro,7936k(firmware),64k(tplink)ro,64k(art)ro
   SUPPORTED_DEVICES := archer-c60-v1
 endef
-TARGET_DEVICES += archer-c25-v1 archer-c59-v1
+TARGET_DEVICES += archer-c25-v1 archer-c58-v1 archer-c59-v1 archer-c60-v1
 
 define Device/archer-c5-v1
   $(Device/tplink-16mlzma)
@@ -1043,6 +1043,7 @@ define Device/tl-wr902ac-v1
        append-metadata | check-size $$$$(IMAGE_SIZE)
   MTDPARTS := spi0.0:128k(u-boot)ro,7360k(firmware),640k(tplink)ro,64k(art)ro
 endef
+TARGET_DEVICES += tl-wr902ac-v1
 
 define Device/tl-wr940n-v4
   $(Device/tplink-4mlzma)
@@ -1114,7 +1115,7 @@ define Device/tl-wr942n-v1
   IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade | \
        append-metadata | check-size $$$$(IMAGE_SIZE)
   IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
-  MTDPARTS := spi0.0:128k(u-boot)ro,1344k(kernel),13120k(rootfs),64k(product-info)ro,64k(partition-table)ro,256k(oem-config)ro,1344k(oem-vars)ro,64k(ART)ro,14464k@0x20000(firmware)
+  MTDPARTS := spi0.0:128k(u-boot)ro,14464k(firmware),64k(product-info)ro,64k(partition-table)ro,256k(oem-config)ro,1344k(oem-vars)ro,64k(ART)ro
   SUPPORTED_DEVICES := tl-wr942n-v1
 endef
-TARGET_DEVICES += tl-wr940n-v4 tl-wr941nd-v2 tl-wr941nd-v3 tl-wr941nd-v4 tl-wr941nd-v5 tl-wr941nd-v6 tl-wr941nd-v6-cn
+TARGET_DEVICES += tl-wr940n-v4 tl-wr941nd-v2 tl-wr941nd-v3 tl-wr941nd-v4 tl-wr941nd-v5 tl-wr941nd-v6 tl-wr941nd-v6-cn tl-wr942n-v1
index 219d1985acfd7fe18b2798cd29f1a8f6649d20ce..65b37926f6112393c9f03fb295c4de942cd28c9c 100644 (file)
@@ -365,8 +365,8 @@ static struct device_info boards[] = {
                        {"profile", 0x11700, 0x03900},
                        {"default-config", 0x15000, 0x04000},
                        {"user-config", 0x19000, 0x04000},
-                       {"os-image", 0x20000, 0x150000},
-                       {"file-system", 0x170000, 0x678000},
+                       {"os-image", 0x20000, 0x180000},
+                       {"file-system", 0x1a0000, 0x648000},
                        {"certyficate", 0x7e8000, 0x08000},
                        {"radio", 0x7f0000, 0x10000},
                        {NULL, 0, 0}
@@ -439,8 +439,8 @@ static struct device_info boards[] = {
                        {"profile", 0x11700, 0x03900},
                        {"default-config", 0x15000, 0x04000},
                        {"user-config", 0x19000, 0x04000},
-                       {"os-image", 0x20000, 0x150000},
-                       {"file-system", 0x170000, 0x678000},
+                       {"os-image", 0x20000, 0x180000},
+                       {"file-system", 0x1a0000, 0x648000},
                        {"certyficate", 0x7e8000, 0x08000},
                        {"radio", 0x7f0000, 0x10000},
                        {NULL, 0, 0}
@@ -730,8 +730,8 @@ static struct device_info boards[] = {
                */
                .partitions = {
                        {"fs-uboot", 0x00000, 0x20000},
-                       {"os-image", 0x20000, 0x160000},
-                       {"file-system", 0x180000, 0x5d0000},
+                       {"os-image", 0x20000, 0x180000},
+                       {"file-system", 0x1a0000, 0x5b0000},
                        {"default-mac", 0x750000, 0x00200},
                        {"pin", 0x750200, 0x00200},
                        {"product-info", 0x750400, 0x0fc00},
@@ -763,8 +763,8 @@ static struct device_info boards[] = {
 
                .partitions = {
                        {"fs-uboot", 0x00000, 0x20000},
-                       {"os-image", 0x20000, 0x150000},
-                       {"file-system", 0x170000, 0xcd0000},
+                       {"os-image", 0x20000, 0x180000},
+                       {"file-system", 0x1a0000, 0xca0000},
                        {"default-mac", 0xe40000, 0x00200},
                        {"pin", 0xe40200, 0x00200},
                        {"product-info", 0xe40400, 0x0fc00},