use immediate set in target Makefiles
[openwrt/openwrt.git] / target / linux / xburst / Makefile
index 259ffb980f161720b5e135ad6e65a5d305f59e15..2a64b7c46fa04b8693105d809469a050354bd751 100644 (file)
@@ -10,16 +10,16 @@ ARCH:=mipsel
 BOARD:=xburst
 BOARDNAME:=Ingenic XBurst
 FEATURES:=targz nand ubifs audio
-SUBTARGETS:=qi_lb60 n516 n526 id800wt
+SUBTARGETS:=qi_lb60
 
-LINUX_VERSION:=3.10.36
+KERNEL_PATCHVER:=3.18
 
-DEVICE_TYPE=other
-
-include $(INCLUDE_DIR)/target.mk
+DEVICE_TYPE:=other
 
 define Target/Description
        Build firmware images for XBurst JZ47x0 based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))