gemini: In-flight ethernet patches
[openwrt/openwrt.git] / target / linux / x86 / base-files.mk
index 29cbfda97782654605a8b5fb110cdfb0761f6809..e2b7d05f57379e79cfec98868847b71c925aa29a 100644 (file)
@@ -1,4 +1,8 @@
+GRUB_SERIAL:=$(call qstrip,$(CONFIG_TARGET_SERIAL))
+ifeq ($(GRUB_SERIAL),)
+$(error This platform requires CONFIG_TARGET_SERIAL be set!)
+endif
+
 define Package/base-files/install-target
-       rm -f $(1)/etc/config/network
+       $(SED) "s#@GRUB_SERIAL@#$(GRUB_SERIAL)#" $(1)/etc/inittab
 endef
-