include/rootfs: skip removal of APK cache now deprecated
[openwrt/openwrt.git] / target / linux / x86 / Makefile
index 660ea26e044751e521fe18b56305b1f92aedda25..b4ac2a5ec8410c41b911c3804c36a7119ae95d81 100644 (file)
@@ -1,24 +1,32 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
-# Copyright (C) 2006-2008 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# Copyright (C) 2006-2011 OpenWrt.org
+
 include $(TOPDIR)/rules.mk
 
-ARCH=i386
+ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2 vdi vmdk
-SUBTARGETS=generic
+FEATURES:=squashfs ext4 vdi vmdk vhdx pcmcia targz fpu boot-part rootfs-part
+SUBTARGETS:=generic legacy geode 64
 
-LINUX_VERSION:=2.6.28.7
+KERNEL_PATCHVER:=6.1
+KERNEL_TESTING_PATCHVER:=6.6
+
+KERNELNAME:=bzImage
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
+
+DEFAULT_PACKAGES += \
+       partx-utils mkf2fs \
+       e2fsprogs kmod-button-hotplug \
+       grub2-bios-setup
 
 $(eval $(call BuildTarget))
 
-$(eval $(call $(if $(CONFIG_TARGET_ROOTFS_ISO),RequireCommand,Ignore),mkisofs, \
-       Please install mkisofs. \
+$(eval $(call $(if $(CONFIG_ISO_IMAGES),SetupHostCommand,Ignore),mkisofs, \
+       Please install mkisofs. , \
+       mkisofs -v 2>&1 , \
+       genisoimage -v 2>&1 | grep genisoimage, \
+       xorrisofs -v 2>&1 | grep xorriso \
 ))