qualcommax: ipq807x: add support for Linksys MX8500
[openwrt/openwrt.git] / target / linux / x86 / Makefile
index 1b8d45f32aeea3e98a45403135a1bb226450237b..b4ac2a5ec8410c41b911c3804c36a7119ae95d81 100644 (file)
@@ -1,25 +1,26 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2006-2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs ext4 vdi vmdk pcmcia targz fpu boot-part rootfs-part
+FEATURES:=squashfs ext4 vdi vmdk vhdx pcmcia targz fpu boot-part rootfs-part
 SUBTARGETS:=generic legacy geode 64
 
-KERNEL_PATCHVER:=5.4
-KERNEL_TESTING_PATCHVER:=5.4
+KERNEL_PATCHVER:=6.1
+KERNEL_TESTING_PATCHVER:=6.6
 
 KERNELNAME:=bzImage
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs
+DEFAULT_PACKAGES += \
+       partx-utils mkf2fs \
+       e2fsprogs kmod-button-hotplug \
+       grub2-bios-setup
 
 $(eval $(call BuildTarget))