ramips: add profile and build image for the Upvel UR-326N4G board
[openwrt/openwrt.git] / target / linux / ramips / rt305x / profiles / upvel.mk
index fa1c9936d7201c6f659608c6fa7cefb3b80c779e..aff2b94ee0c6fa349e677705c7d1de5f33c858d9 100644 (file)
@@ -16,3 +16,15 @@ define Profile/UPVEL/Description
        Default package set compatible with URVEL router board.
 endef
 $(eval $(call Profile,UPVEL))
+
+define Profile/UPVEL_326
+       NAME:=UPVEL UR-326N4G
+       PACKAGES:=\
+               kmod-usb-core kmod-usb-rt305x-dwc_otg \
+               kmod-ledtrig-usbdev
+endef
+
+define Profile/UPVEL/Description
+       Default package set compatible with URVEL router board.
+endef
+$(eval $(call Profile,UPVEL_326))