ramips: add profile and build image for the Tenda 3G300M
[openwrt/openwrt.git] / target / linux / ramips / rt305x / profiles / tenda.mk
index 5e45b5f91309c81df7ab7b243ba1d7d271399f72..10a4cb30779829b2db1c2bea81f91c3b447e215a 100644 (file)
@@ -5,6 +5,19 @@
 # See /LICENSE for more information.
 #
 
+define Profile/3G300M
+       NAME:=Tenda 3G300M
+       PACKAGES:=\
+               kmod-usb-core kmod-usb-rt305x-dwc_otg \
+               kmod-ledtrig-usbdev
+endef
+
+define Profile/3G300M/Description
+       Package set for Tenda 3G300M board
+endef
+
+$(eval $(call Profile,3G300M))
+
 define Profile/W306R_V20
        NAME:=Tenda W306R V2.0
        PACKAGES:=