ramips: add support for ZyXEL Keenetic 4G Rev.B Device
[openwrt/openwrt.git] / target / linux / ramips / image / rt305x.mk
index 708aeb8555ce2d4a593bbe332b2327dcd96341b5..6b8dada3c91f93ffb84387ba370e715b89003195 100644 (file)
@@ -1206,6 +1206,16 @@ define Device/zyxel_keenetic
 endef
 TARGET_DEVICES += zyxel_keenetic
 
+define Device/zyxel_keenetic-4g-b
+  $(Device/uimage-lzma-loader)
+  SOC := rt5350
+  IMAGE_SIZE := 7872k
+  DEVICE_VENDOR := ZyXEL
+  DEVICE_MODEL := Keenetic 4G
+  DEVICE_VARIANT := B
+endef
+TARGET_DEVICES += zyxel_keenetic-4g-b
+
 define Device/zyxel_keenetic-lite-b
   $(Device/uimage-lzma-loader)
   SOC := rt5350