ramips: add support for TOZED ZLT S12 PRO
[openwrt/openwrt.git] / target / linux / ramips / image / mt7621.mk
index fc532966c8c1bfb22f954a8bd093e5f6c02a90df..f717fea5d4979e002bc1622a3085ee50913f244e 100644 (file)
@@ -2135,6 +2135,16 @@ define Device/totolink_x5000r
 endef
 TARGET_DEVICES += totolink_x5000r
 
+define Device/tozed_zlt-s12-pro
+  $(Device/dsa-migration)
+  $(Device/uimage-lzma-loader)
+  IMAGE_SIZE := 16064k
+  DEVICE_VENDOR := TOZED
+  DEVICE_MODEL := ZLT S12 PRO
+  DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 comgt-ncm -uboot-envtools
+endef
+TARGET_DEVICES += tozed_zlt-s12-pro
+
 define Device/tplink_archer-ax23-v1
   $(Device/dsa-migration)
   $(Device/tplink-safeloader)