ramips: add support for Cudy M1800
[openwrt/openwrt.git] / target / linux / ramips / image / mt7621.mk
index 1b4e1dc0398a38532e32744954787d4e40c6375b..2fc193634b09b885ed7a1849936cfeba30395312 100644 (file)
@@ -426,6 +426,16 @@ define Device/bolt_arion
 endef
 TARGET_DEVICES += bolt_arion
 
+define Device/cudy_m1800
+  $(Device/dsa-migration)
+  DEVICE_VENDOR := Cudy
+  DEVICE_MODEL := M1800
+  IMAGE_SIZE := 16064k
+  UIMAGE_NAME := R17
+  DEVICE_PACKAGES := kmod-mt7915e
+endef
+TARGET_DEVICES += cudy_m1800
+
 define Device/cudy_wr1300-v1
   $(Device/dsa-migration)
   IMAGE_SIZE := 15872k