ramips: add support for Sanlinking D240
[openwrt/openwrt.git] / target / linux / ramips / image / mt7620.mk
index 446bd9981e28bec21f62416fcca05b85d8ec8f2a..29006845ced676cde5572118ab964af6cbbb675e 100644 (file)
@@ -465,3 +465,11 @@ define Device/kng_rc
        zyimage -d 8997 -v "ZyXEL Keenetic Viva"
 endef
 TARGET_DEVICES += kng_rc
+
+define Device/d240
+  DTS := D240
+  IMAGE_SIZE := $(ralink_default_fw_size_16M)
+  DEVICE_TITLE := Sanlinking Technologies D240
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-mt76 kmod-sdhci-mt7620
+endef
+TARGET_DEVICES += d240