ramips: rt288x: add support for the Belkin F5D8235-4 v1 board
[openwrt/openwrt.git] / target / linux / ramips / image / Makefile
index b661cab558be14806585b68100a613880838aa0d..d177c04ba8565cd5630189ea0de33d7412380fa5 100644 (file)
@@ -257,6 +257,10 @@ define Image/Build/Profile/F5D8235V2
        $(call Image/Build/Template/F5D8235V2,$(1),f5d8235v2,F5D8235_V2)
 endef
 
+define Image/Build/Template/F5D8235V1
+       $(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_f5d8235,$(mtd_f5d8235_kernel_part_size),$(mtd_f5d8235_rootfs_part_size))
+endef
+
 
 mtdlayout_wr5123gn=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),2944k(rootfs),3776k@0x50000(firmware)
 mtdlayout_wr5123gn8m=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),7040k(rootfs),7872k@0x50000(firmware)
@@ -265,7 +269,6 @@ define Image/Build/Profile/WR5123GN
        $(call BuildFirmware/Generic,$(1),wr512-3gn-8M,board="WR512-3GN",mtdlayout_wr5123gn8m,851968,7208960)
 endef
 
-
 ifeq ($(CONFIG_RALINK_RT305X),y)
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/ARGUS_ATP52B,$(1))
@@ -290,6 +293,9 @@ define Image/Build/Profile/Default
 endef
 endif
 
+define Image/Build/Profile/F5D8235V1
+       $(call Image/Build/Template/F5D8235V1,$(1),f5d8235v1,F5D8235_V1)
+endef
 
 define Image/Build/Profile/RTN15
        $(call Image/Build/Template/GENERIC_4M,$(1),rt-n15,RT-N15)
@@ -302,6 +308,7 @@ endef
 
 ifeq ($(CONFIG_RALINK_RT288X),y)
 define Image/Build/Profile/Default
+       $(call Image/Build/Profile/F5D8235V1,$(1))
        $(call Image/Build/Profile/RTN15,$(1))
        $(call Image/Build/Profile/WLITX4AG300N,$(1))
 endef