ramips: generate sysupgrade image for the ALL0256N
[openwrt/openwrt.git] / target / linux / ramips / image / Makefile
index d177c04ba8565cd5630189ea0de33d7412380fa5..c6b214ff36b2b1b183c5ccf55ef6bec22ee1fb2e 100644 (file)
@@ -181,6 +181,10 @@ define Image/Build/Profile/BC2
        $(call Image/Build/Template/GENERIC_8M,$(1),bc2,BC2)
 endef
 
+define Image/Build/Profile/ALL0256N
+       $(call Image/Build/Template/GENERIC_4M,$(1),all0256n,ALL0256N)
+endef
+
 define Image/Build/Profile/NBG419N
        $(call Image/Build/Template/GENERIC_4M,$(1),nbg-419n,NBG-419N)
 endef
@@ -273,6 +277,7 @@ ifeq ($(CONFIG_RALINK_RT305X),y)
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/ARGUS_ATP52B,$(1))
        $(call Image/Build/Profile/BC2,$(1))
+       $(call Image/Build/Profile/ALL0256N,$(1))
        $(call Image/Build/Profile/DIR300B1,$(1))
        $(call Image/Build/Profile/ESR9753,$(1))
        $(call Image/Build/Profile/RTG32B1,$(1))