ramips: rt305x: add support for the Skyline SL-R7205 Wireless 3G router
[openwrt/openwrt.git] / target / linux / ramips / image / Makefile
index b661cab558be14806585b68100a613880838aa0d..588dfa55fb19076997fe2557d6da0a6025145f4f 100644 (file)
@@ -67,6 +67,28 @@ define BuildFirmware/Generic
        fi; fi
 endef
 
+define BuildFirmware/WL341V3
+       $(call PatchKernelLzma,$(2),$(3) $($(4)))
+       $(call MkImage,lzma,"$(KDIR)/vmlinux-$(2).bin.lzma","$(KDIR)/vmlinux-$(2).uImage")
+       if [ `stat -c%s "$(KDIR)/vmlinux-$(2).uImage"` -gt $(5) ]; then \
+               echo "Warning: $(KDIR)/vmlinux-$(2).uImage is too big"; \
+       else if [ `stat -c%s $(KDIR)/root.$(1)` -gt $(6) ]; then \
+               echo "Warning: $(KDIR)/root.$(1) is too big"; \
+       else \
+               ( \
+                       dd if=/dev/zero bs=195936 count=1; \
+                       echo "1.01"; \
+                       dd if=/dev/zero bs=581 count=1; \
+                       echo -n -e "\x73\x45\x72\x43\x6F\x4D\x6D\x00\x01\x00\x00\x59\x4E\x37\x95\x58\x10\x00\x20\x00\x28\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x11\x03\x00\x00\x80\x00\x00\x00\x00\x03\x00\x00\x10\x12\x00\x00\x00\x10\x73\x45\x72\x43\x6F\x4D\x6D"; \
+                       dd if=/dev/zero bs=65552 count=1; \
+                       dd if=$(KDIR)/vmlinux-$(2).uImage bs=$(5) conv=sync; \
+                       dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
+                       dd if=/dev/zero bs=`expr 4194304 - 262144 - 16 - $(5) - \( \( \( \`stat -c%s $(KDIR)/root.$(1)\` / 65536 \) + 1 \) \* 65536 \)` count=1; \
+                       echo -n -e "\x11\x03\x80\x00\x10\x12\x90\xF7\x65\x52\x63\x4F\x6D\x4D\x00\x00"; \
+               ) > $(call imgname,$(1),$(2))-factory.bin; \
+       fi; fi
+endef
+
 define BuildFirmware/Buffalo
        $(call PatchKernelLzma,$(2),board=$(3) $($(4)))
        $(call MkImage,lzma,"$(KDIR)/vmlinux-$(2).bin.lzma","$(KDIR)/vmlinux-$(2).uImage")
@@ -145,12 +167,32 @@ define Image/Build/Template/NW718
        $(call BuildFirmware/NW718,$(1),$(2),board=$(3),mtdlayout_nw718,851968,2949120)
 endef
 
+console_WR6202=ttyS1,115200
+mtdlayout_WR6202=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,1024k(kernel),6848k(rootfs),7872k@0x50000(firmware)
+define Image/Build/Template/WR6202
+       $(call BuildFirmware/Generic,$(1),$(2),board=$(3) console=$(console_WR6202),mtdlayout_WR6202,1048576,7012352)
+endef
+
+define Image/Build/Profile/WR6202
+       $(call Image/Build/Template/WR6202,$(1),wr6202,WR6202)
+endef
+
 console_OMNIEMB=ttyS1,57600
 mtdlayout_ONMIEMB=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,1024k(kernel),6848k(rootfs),7872k@0x50000(firmware)
 define Image/Build/Template/OMNIEMB
        $(call BuildFirmware/Generic,$(1),$(2),board=$(3) console=$(console_OMNIEMB),mtdlayout_OMNIEMB,1048576,7012352)
 endef
 
+mtdlayout_sercomm_4M=mtdparts=physmap-flash.0:128k(u-boot)ro,64k(board-nvram)ro,64k(u-boot-env)ro,832k(kernel),2944k(rootfs),64k(signature-eRcOmM),3776k@0x40000(firmware),4096k@0x0(fullflash)
+define Image/Build/Template/WL341V3
+       $(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_sercomm_4M,851968,3014656)
+       $(call BuildFirmware/WL341V3,$(1),$(2),board=$(3),mtdlayout_sercomm_4M,851968,3014656)
+endef
+
+define Image/Build/Profile/WL341V3
+       $(call Image/Build/Template/WL341V3,$(1),wl341v3,WL341V3)
+endef
+
 define Image/Build/Profile/DIR300B1
        $(call Image/Build/Template/DIR300B1,$(1),dir-300-b1,DIR-300-B1,wrgn23_dlwbr_dir300b)
        $(call Image/Build/Template/DIR300B1,$(1),dir-600-b1,DIR-600-B1,wrgn23_dlwbr_dir600b)
@@ -181,6 +223,11 @@ define Image/Build/Profile/BC2
        $(call Image/Build/Template/GENERIC_8M,$(1),bc2,BC2)
 endef
 
+mtdlayout_all0256n=mtdparts=spi0.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),2944k(rootfs),3776k@0x50000(firmware)
+define Image/Build/Profile/ALL0256N
+       $(call BuildFirmware/Generic,$(1),all0256n,board=ALL0256N,mtdlayout_all0256n,851968,3014656)
+endef
+
 define Image/Build/Profile/NBG419N
        $(call Image/Build/Template/GENERIC_4M,$(1),nbg-419n,NBG-419N)
 endef
@@ -257,19 +304,24 @@ define Image/Build/Profile/F5D8235V2
        $(call Image/Build/Template/F5D8235V2,$(1),f5d8235v2,F5D8235_V2)
 endef
 
+define Image/Build/Template/F5D8235V1
+       $(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_f5d8235,$(mtd_f5d8235_kernel_part_size),$(mtd_f5d8235_rootfs_part_size))
+endef
 
-mtdlayout_wr5123gn=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),2944k(rootfs),3776k@0x50000(firmware)
-mtdlayout_wr5123gn8m=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),7040k(rootfs),7872k@0x50000(firmware)
 define Image/Build/Profile/WR5123GN
-       $(call BuildFirmware/Generic,$(1),wr512-3gn-4M,board="WR512-3GN",mtdlayout_wr5123gn,851968,3014656)
-       $(call BuildFirmware/Generic,$(1),wr512-3gn-8M,board="WR512-3GN",mtdlayout_wr5123gn8m,851968,7208960)
+       $(call Image/Build/Template/GENERIC_4M,$(1),wr512-3gn-4M,WR512-3GN)
+       $(call Image/Build/Template/GENERIC_8M,$(1),wr512-3gn-8M,WR512-3GN)
 endef
 
+define Image/Build/Profile/SLR7205
+       $(call Image/Build/Template/GENERIC_4M,$(1),sl-r7205,SL-R7205)
+endef
 
 ifeq ($(CONFIG_RALINK_RT305X),y)
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/ARGUS_ATP52B,$(1))
        $(call Image/Build/Profile/BC2,$(1))
+       $(call Image/Build/Profile/ALL0256N,$(1))
        $(call Image/Build/Profile/DIR300B1,$(1))
        $(call Image/Build/Profile/ESR9753,$(1))
        $(call Image/Build/Profile/RTG32B1,$(1))
@@ -279,6 +331,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/NW718,$(1))
        $(call Image/Build/Profile/OMNIEMB,$(1))
        $(call Image/Build/Profile/PWH2004,$(1))
+       $(call Image/Build/Profile/SLR7205,$(1))
        $(call Image/Build/Profile/WHRG300N,$(1))
        $(call Image/Build/Profile/WCR150GN,$(1))
        $(call Image/Build/Profile/F5D8235V2,$(1))
@@ -286,10 +339,15 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/MOFI35003GN,$(1))
        $(call Image/Build/Profile/W502U,$(1))
        $(call Image/Build/Profile/WR5123GN,$(1))
+       $(call Image/Build/Profile/WL341V3,$(1))
        $(call Image/Build/Profile/WL351,$(1))
+       $(call Image/Build/Profile/WR6202,$(1))
 endef
 endif
 
+define Image/Build/Profile/F5D8235V1
+       $(call Image/Build/Template/F5D8235V1,$(1),f5d8235v1,F5D8235_V1)
+endef
 
 define Image/Build/Profile/RTN15
        $(call Image/Build/Template/GENERIC_4M,$(1),rt-n15,RT-N15)
@@ -302,6 +360,7 @@ endef
 
 ifeq ($(CONFIG_RALINK_RT288X),y)
 define Image/Build/Profile/Default
+       $(call Image/Build/Profile/F5D8235V1,$(1))
        $(call Image/Build/Profile/RTN15,$(1))
        $(call Image/Build/Profile/WLITX4AG300N,$(1))
 endef