ramips: rt305x: add add support for the Asus WL-330N board
[openwrt/openwrt.git] / target / linux / ramips / image / Makefile
index bb6124c9abfa8c95e1bce1f5513faf07aacb03cd..3499c9e765f17620c4f2634dd5b8ac3a2bee2405 100644 (file)
@@ -164,6 +164,10 @@ define BuildFirmware/DIR300B1
                -o $(call imgname,$(1),$(2))-factory.bin
 endef
 
+define BuildFirmware/DIR300B1/initramfs
+       $(call BuildFirmware/Generic/initramfs,$(1),$(2),board=$(3) $(call mkmtd/phys,$(mtdlayout_dir300b1)),$(mtd_dir300b1_kernel_part_size),$(mtd_dir300b1_rootfs_part_size))
+endef
+
 define BuildFirmware/Edimax
        if [ -e "$(call sysupname,$(1),$(2))" ]; then \
                mkedimaximg -i $(call sysupname,$(1),$(2)) \
@@ -374,6 +378,10 @@ define Image/Build/Profile/WHRG300N
        $(call Image/Build/Template/$(fs_squashfs)/$(1),WHRG300N)
 endef
 
+define Image/Build/Profile/WL_330N
+       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,wl-330n,WL_330N,ttyS1,57600,spi)
+endef
+
 define Image/Build/Profile/WL341V3
        $(call Image/Build/Template/$(fs_squash)/$(1),WL341V3,wl341v3,WL341V3)
 endef
@@ -391,6 +399,10 @@ define Image/Build/Profile/WR6202
        $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,wr6202,WR6202,ttyS1,115200,phys)
 endef
 
+define Image/Build/Profile/XDXRN502J
+       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,xdxrn502j,XDXRN502J,ttyS1,57600,phys)
+endef
+
 ifeq ($(CONFIG_RALINK_RT305X),y)
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/ALL0256N,$(1))
@@ -413,10 +425,12 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/W502U,$(1))
        $(call Image/Build/Profile/WCR150GN,$(1))
        $(call Image/Build/Profile/WHRG300N,$(1))
+       $(call Image/Build/Profile/WL_330N,$(1))
        $(call Image/Build/Profile/WL341V3,$(1))
        $(call Image/Build/Profile/WL351,$(1))
        $(call Image/Build/Profile/WR5123GN,$(1))
        $(call Image/Build/Profile/WR6202,$(1))
+       $(call Image/Build/Profile/XDXRN502J,$(1))
 endef
 endif