ramips: rt3883: add profile and build sysupgrade image for the RT-N56U
[openwrt/openwrt.git] / target / linux / ramips / image / Makefile
index d310d26032c79e71bd784431297a58f5b794714a..1330fa318b2331d9f16030b7b843fdf7c5c684e3 100644 (file)
@@ -449,6 +449,19 @@ define Image/Build/Profile/Default
 endef
 endif
 
+#
+# RT3662/RT3883 Profiles
+#
+define Image/Build/Profile/RTN56U
+       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,rt-n56u,RT-N56U,ttyS1,57600,phys)
+endef
+
+ifeq ($(CONFIG_RALINK_RT3883),y)
+define Image/Build/Profile/Default
+       $(call Image/Build/Profile/RTN56U,$(1))
+endef
+endif
+
 define Image/Build/Initramfs
        $(call Image/Build/Profile/$(PROFILE),initramfs)
 endef