ramips: add support for the ARC FreeStation5 board, also fix WCR-150GN network setup...
[openwrt/openwrt.git] / target / linux / ramips / image / Makefile
index a4d526df18e987806298004cb62239234c030f4e..0c37f7e3524ede66dc0ef5b79698e12f9b1df9cf 100644 (file)
@@ -331,6 +331,10 @@ define Image/Build/Profile/FONERA20N
        $(call Image/Build/Template/$(fs_squash)/$(1),FONERA20N)
 endef
 
+define Image/Build/Profile/FREESTATION5
+       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,freestation5,FREESTATION5,ttyS1,115200,phys)
+endef
+
 define Image/Build/Profile/MOFI35003GN
        $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,mofi3500-3gn,MOFI3500-3GN,ttyS1,57600,phys)
 endef
@@ -414,6 +418,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/F5D8235V2,$(1))
        $(call Image/Build/Profile/RTN10PLUS,$(1))
        $(call Image/Build/Profile/FONERA20N,$(1))
+       $(call Image/Build/Profile/FREESTATION5,$(1))
        $(call Image/Build/Profile/HW5503G,$(1))
        $(call Image/Build/Profile/MOFI35003GN,$(1))
        $(call Image/Build/Profile/NBG419N,$(1))