ramips: purge default packages on MT7621
[openwrt/openwrt.git] / target / linux / ramips / Makefile
index d3d2db789b70eaeb8f373829c985a70fe1da153d..1de220e1a30477c3ba7d8a4998756b68e307d040 100644 (file)
@@ -8,19 +8,19 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=ramips
-BOARDNAME:=Ralink RT288x/RT3xxx
-SUBTARGETS:=rt305x mt7620a mt7620n mt7621 mt7628 rt3883 rt288x
+BOARDNAME:=MediaTek Ralink MIPS
+SUBTARGETS:=rt305x mt7620 mt7621 mt7628 mt7688 rt3883 rt288x
 FEATURES:=squashfs gpio
-MAINTAINER:=John Crispin <blogic@openwrt.org>
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-KERNEL_PATCHVER:=3.14
-
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-gpio-button-hotplug wpad-mini swconfig
+KERNEL_PATCHVER:=4.4
 
 define Target/Description
        Build firmware images for Ralink RT288x/RT3xxx based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+       kmod-leds-gpio kmod-gpio-button-hotplug swconfig
+
 $(eval $(call BuildTarget))