octeon: fix mtd partitions for erlite on cmdline
[openwrt/openwrt.git] / target / linux / octeon / image / Makefile
index 7189a9cffa7b5a459696c287586bc55ba9f00422..299e9ba3965435acb8a00d7cefc02a5df79ccb80 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,20 +7,39 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-define Image/BuildKernel
+define Device/Default
+  PROFILES = Default $$(DEVICE_NAME)
+  KERNEL_NAME := vmlinux.elf
+  KERNEL_INITRAMFS_NAME := vmlinux-initramfs.elf
+  KERNEL := kernel-bin | strip-kernel | patch-cmdline
+  IMAGES := sysupgrade.tar
+  IMAGE/sysupgrade.tar/squashfs := append-rootfs | pad-extra 128k | sysupgrade-tar rootfs=$$$$@
+  IMAGE/sysupgrade.tar := sysupgrade-tar
+endef
+
+define Build/strip-kernel
        # Workaround pre-SDK-1.9.0 u-boot versions not handling the .notes section
-       $(TARGET_CROSS)strip -R .notes $(KDIR)/vmlinux.elf -o $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
-       $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.bin.l7
-       dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma bs=65536 conv=sync
+       $(TARGET_CROSS)strip -R .notes $@ -o $@.stripped && mv $@.stripped $@
+endef
+
+define Device/generic
+  FILESYSTEMS := ext4
+  DEVICE_TITLE := Generic
 endef
+TARGET_DEVICES += generic
 
-define Image/Build/squashfs
-    $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ER_CMDLINE:=-mtdparts=phys_mapped_flash:640k(boot0)ro,640k(boot1)ro,64k(eeprom)ro root=/dev/mmcblk0p2 rootfstype=squashfs,ext4 rootwait
+define Device/er
+  CMDLINE := $(ER_CMDLINE) 
+  DEVICE_TITLE := Ubiquiti EdgeRouter
 endef
+TARGET_DEVICES += er
 
-define Image/Build
-       $(call Image/Build/$(1))
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
+ERLITE_CMDLINE:=-mtdparts=phys_mapped_flash:512k(boot0)ro,512k(boot1)ro,64k(eeprom)ro root=/dev/sda2 rootfstype=squashfs,ext4 rootwait
+define Device/erlite
+  CMDLINE := $(ERLITE_CMDLINE) 
+  DEVICE_TITLE := Ubiquiti EdgeRouter Lite
 endef
+TARGET_DEVICES += erlite
 
 $(eval $(call BuildImage))