mvebu: add support for the Linksys Caiman and Cobra
[openwrt/openwrt.git] / target / linux / mvebu / profiles / linksys.mk
index 1bacb971d9ada895b61c36dd92b197e79efb01fb..ed20cb0cf2eaec5713804a9295bb47dc189d0c3d 100644 (file)
@@ -5,6 +5,46 @@
 # See /LICENSE for more information.
 #
 
+define Profile/Caiman
+  NAME:=Linksys WRT1200AC (Caiman)
+  PACKAGES:= \
+       kmod-usb2 kmod-usb3 kmod-usb-storage \
+       kmod-i2c-core kmod-i2c-mv64xxx \
+       kmod-ata-core kmod-ata-mvebu-ahci \
+       kmod-rtc-armada38x kmod-thermal-armada \
+       kmod-gpio-button-hotplug kmod-hwmon-tmp421 \
+       kmod-leds-pca963x \
+       kmod-ledtrig-usbdev kmod-mwlwifi wpad-mini \
+       swconfig
+endef
+
+define Profile/Caiman/Description
+ Package set compatible with the Linksys WRT1200AC (Caiman).
+endef
+
+$(eval $(call Profile,Caiman))
+
+
+define Profile/Cobra
+  NAME:=Linksys WRT1900ACv2 (Cobra)
+  PACKAGES:= \
+       kmod-usb2 kmod-usb3 kmod-usb-storage \
+       kmod-i2c-core kmod-i2c-mv64xxx \
+       kmod-ata-core kmod-ata-mvebu-ahci \
+       kmod-rtc-armada38x kmod-thermal-armada \
+       kmod-gpio-button-hotplug kmod-hwmon-tmp421 \
+       kmod-leds-pca963x \
+       kmod-ledtrig-usbdev kmod-mwlwifi wpad-mini \
+       swconfig
+endef
+
+define Profile/Cobra/Description
+ Package set compatible with the Linksys WRT1900AC (Cobra).
+endef
+
+$(eval $(call Profile,Cobra))
+
+
 define Profile/Mamba
   NAME:=Linksys WRT1900AC (Mamba)
   PACKAGES:= \