use immediate set in target Makefiles
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index efd48d7d41cc3d93fd60dde2cf6c7bd0e2996d46..161c8cb8168fb25e4c98a6f280f57f6425ef99ab 100644 (file)
@@ -12,10 +12,14 @@ BOARDNAME:=Freescale MPC85xx
 CPU_TYPE:=8540
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-SUBTARGETS=generic p1020
+SUBTARGETS:=generic p1020
 
 KERNEL_PATCHVER:=4.4
 
+define Target/Description
+       Build images for the Freescale MPC85xx based boards.
+endef
+
 include $(INCLUDE_DIR)/target.mk
 
 KERNEL_IMAGES := zImage
@@ -27,8 +31,4 @@ DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
        kmod-leds-gpio swconfig kmod-ath9k wpad-mini
 
-define Target/Description
-       Build images for the Freescale MPC85xx based boards.
-endef
-
 $(eval $(call BuildTarget))