Add support for ARV4518PW R01 and rename R01A.
[openwrt/openwrt.git] / target / linux / lantiq / xway / profiles / arv.mk
index c0c7c7c810cb19ce4d15344653d68f2cd1eaceea..a4f11ca2389c4d238f9d65c7ff6be1c0c2388f53 100644 (file)
@@ -18,8 +18,8 @@ endef
 
 $(eval $(call Profile,ARV7525PW))
 
-define Profile/ARV4518PW
-  NAME:=SMC7908A-ISP, Airties WAV-221 - ARV4518PW
+define Profile/ARV4518PWR01
+  NAME:=ARV4518PWR01
   PACKAGES:=kmod-ltq-hcd-danube kmod-ledtrig-usbdev \
        kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
        kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
@@ -28,7 +28,19 @@ define Profile/ARV4518PW
        swconfig
 endef
 
-$(eval $(call Profile,ARV4518PW))
+$(eval $(call Profile,ARV4518PWR01))
+
+define Profile/ARV4518PWR01A
+  NAME:=ARV4518PWR01A
+  PACKAGES:=kmod-ltq-hcd-danube kmod-ledtrig-usbdev \
+        kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
+        kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
+        ltq-adsl-app ppp-mod-pppoa \
+        kmod-ath5k wpad-mini \
+        swconfig
+endef
+
+$(eval $(call Profile,ARV4518PWR01A))
 
 define Profile/ARV4510PW
   NAME:=Wippies Homebox - ARV4510PW