Add profile and userspace for P2812HNUF1/3, switch from UBI_GLUEBI to UBI_BLOCK
[openwrt/openwrt.git] / target / linux / lantiq / xrx200 / profiles / zyxel.mk
index e758a50360eb63d5c2b8bae276d5f0134d5aa1c1..a43ee1433d6c8140b71a9b170b925e2faa9956bb 100644 (file)
@@ -1,5 +1,5 @@
-define Profile/P2812HNUFX
-  NAME:=ZyXEL P-2812HNU-Fx
+define Profile/P2812HNUF1
+  NAME:=ZyXEL P-2812HNU-F1
   PACKAGES:=kmod-rt2800-pci wpad-mini \
        kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
        kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
@@ -8,7 +8,23 @@ define Profile/P2812HNUFX
        swconfig
 endef
 
-P2812HNUFX_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
-P2812HNUFX_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+P2812HNUF1_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+P2812HNUF1_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,P2812HNUF1))
+
+define Profile/P2812HNUF3
+  NAME:=ZyXEL P-2812HNU-F3
+  PACKAGES:=kmod-rt2800-pci wpad-mini \
+       kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
+       kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
+       kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
+       ltq-vdsl-app ppp-mod-pppoa \
+       swconfig
+endef
+
+P2812HNUF3_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+P2812HNUF3_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,P2812HNUF3))
 
-$(eval $(call Profile,P2812HNUFX))