kernel: bump 4.4 to 4.4.103 for 17.01
[openwrt/openwrt.git] / target / linux / lantiq / patches-4.4 / 0100-spi-add-support-for-Lantiq-SPI-controller.patch
index cc3c851fc7def63c5351f7ca95e126e5d115fa68..daec87c433747f412d7dde5802feef8c8feafa00 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Daniel Schwierzeck <daniel.schwierzeck@gmail.com>
 
 --- a/drivers/spi/Kconfig
 +++ b/drivers/spi/Kconfig
-@@ -346,6 +346,13 @@ config SPI_MT65XX
+@@ -356,6 +356,13 @@ config SPI_MT65XX
          say Y or M here.If you are not sure, say N.
          SPI drivers for Mediatek MT65XX and MT81XX series ARM SoCs.
  
@@ -29,8 +29,8 @@ Signed-off-by: Daniel Schwierzeck <daniel.schwierzeck@gmail.com>
        depends on GPIOLIB || COMPILE_TEST
 --- a/drivers/spi/Makefile
 +++ b/drivers/spi/Makefile
-@@ -44,6 +44,7 @@ obj-$(CONFIG_SPI_FSL_SPI)            += spi-fsl-sp
- obj-$(CONFIG_SPI_GPIO)                        += spi-gpio.o
+@@ -45,6 +45,7 @@ obj-$(CONFIG_SPI_GPIO)                       += spi-gpio.o
+ obj-$(CONFIG_SPI_GPIO_OLD)            += spi_gpio_old.o
  obj-$(CONFIG_SPI_IMG_SPFI)            += spi-img-spfi.o
  obj-$(CONFIG_SPI_IMX)                 += spi-imx.o
 +obj-$(CONFIG_SPI_LANTIQ)              += spi-lantiq.o