use immediate set in target Makefiles
[openwrt/openwrt.git] / target / linux / lantiq / Makefile
index d8c12ed3e59e4552268ffe4d7d049687da0b3f69..d3721f6c2cd9567777089ee483b4cb69dd90335a 100644 (file)
@@ -7,13 +7,14 @@
 include $(TOPDIR)/rules.mk
 
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY/SVIP
+BOARDNAME:=Lantiq
 FEATURES:=squashfs
-SUBTARGETS=xway ase falcon
+SUBTARGETS:=xrx200 xway xway_legacy
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=3.8.13
+KERNEL_PATCHVER:=4.4
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
+CPU_TYPE:=mips32r2
 
 define Target/Description
        Build firmware images for Lantiq SoC