kirkwood: add ZyXEL NSA325 device
[openwrt/openwrt.git] / target / linux / kirkwood / image / Makefile
index ece7c1adf6ec67280743b7082b4a991f82e27a77..141505e002b7e42f0350b4cbe33491557afb632c 100644 (file)
@@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 KERNEL_LOADADDR:=0x8000
-TARGET_DEVICES = linksys-audi linksys-viper dockstar goflexnet goflexhome iconnect pogo_e02 ib62x0 nsa310b
+TARGET_DEVICES = linksys-audi linksys-viper dockstar goflexnet goflexhome iconnect pogo_e02 ib62x0 nsa310b nsa325
 
 UBI_OPTS := -m 2048 -p 128KiB -s 512
 UBIFS_OPTS := -m 2048 -e 126KiB -c 4096
@@ -87,6 +87,13 @@ $(Device/dockstar)
   DEVICE_PACKAGES := kmod-r8169 kmod-gpio-button-hotplug kmod-hwmon-lm85
 endef
 
+define Device/nsa325
+$(Device/dockstar)
+  DEVICE_TITLE := ZyXEL NSA325 (v1 and v2)
+  DEVICE_DTS := kirkwood-nsa325
+  DEVICE_PACKAGES := kmod-gpio-button-hotplug kmod-rtc-pcf8563 kmod-usb3
+endef
+
 define Device/pogo_e02
 $(Device/dockstar)
   DEVICE_TITLE := Cloud Engines Pogoplug E02