use immediate set in target Makefiles
[openwrt/openwrt.git] / target / linux / ixp4xx / Makefile
index d8793068cd0bc6e6680fd67ad73f4656fcd62086..a185ce8df59ca5d6a0795519f1066bde65c1e049 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,18 +10,14 @@ ARCH:=armeb
 BOARD:=ixp4xx
 BOARDNAME:=Intel IXP4xx
 FEATURES:=squashfs
-SUBTARGETS=generic harddisk
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+SUBTARGETS:=generic harddisk
 
-LINUX_VERSION:=2.6.28.4
+KERNEL_PATCHVER:=4.4
 
 include $(INCLUDE_DIR)/target.mk
 
-define Kernel/Configure
-       $(call Kernel/Configure/Default)
-       $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
-       $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
-endef
-
 DEFAULT_PACKAGES += ixp4xx-microcode fconfig
+KERNELNAME:=zImage
 
 $(eval $(call BuildTarget))