ipq806x: Add support for Netgear D7800
[openwrt/openwrt.git] / target / linux / ipq806x / profiles / netgear.mk
index 3402f45853aa3a22c1012949eb94bc63277db66e..25258cdca3ff94fa167a05ae54657ed7da807878 100644 (file)
@@ -6,6 +6,18 @@
 # See /LICENSE for more information.
 #
 
+define Profile/D7800
+       NAME:=Netgear Nighthawk X4 D7800
+       PACKAGES:= \
+               kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev \
+               kmod-usb3 kmod-usb-dwc3-qcom kmod-usb-phy-qcom-dwc3 \
+               kmod-ath10k wpad-mini ath10k-firmware-qca99x0
+endef
+
+define Profile/D7800/Description
+       Package set for the Netgear Nighthawk X4 D7800.
+endef
+
 define Profile/R7500
        NAME:=Netgear Nighthawk X4 R7500
        PACKAGES:= \
@@ -17,4 +29,5 @@ endef
 define Profile/R7500/Description
        Package set for the Netgear Nighthawk X4 R7500.
 endef
+$(eval $(call Profile,D7800))
 $(eval $(call Profile,R7500))