ipq806x: convert each device to DSA implementation
[openwrt/openwrt.git] / target / linux / ipq806x / image / generic.mk
index a3e9eb59e723650d48ae4a33d526e37dbcda9f48..0339a612d8e26e2db0090eeaeba8ab08dd395fee 100644 (file)
@@ -8,6 +8,16 @@ define Device/kernel-size-migration
        use the force flag when image check fails. Settings will be lost. ***
 endef
 
+define Device/dsa-migration
+  DEVICE_COMPAT_VERSION := 1.1
+  DEVICE_COMPAT_MESSAGE := Config cannot be migrated from swconfig to DSA
+endef
+
+define Device/dsa-migration-from-2_0
+  DEVICE_COMPAT_VERSION := 2.1
+  DEVICE_COMPAT_MESSAGE := Config cannot be migrated from swconfig to DSA
+endef
+
 define Build/buffalo-rootfs-cksum
        ( \
                echo -ne "\x$$(od -A n -t u1 $@ | tr -s ' ' '\n' | \
@@ -67,6 +77,7 @@ endef
 
 define Device/arris_tr4400-v2
        $(call Device/LegacyImage)
+       $(Device/dsa-migration)
        DEVICE_VENDOR := Arris
        DEVICE_MODEL := TR4400
        DEVICE_VARIANT := v2
@@ -80,6 +91,7 @@ TARGET_DEVICES += arris_tr4400-v2
 
 define Device/askey_rt4230w-rev6
        $(call Device/LegacyImage)
+       $(Device/dsa-migration)
        DEVICE_VENDOR := Askey
        DEVICE_MODEL := RT4230W
        DEVICE_VARIANT := REV6
@@ -94,6 +106,7 @@ TARGET_DEVICES += askey_rt4230w-rev6
 define Device/asrock_g10
        $(call Device/FitImage)
        $(call Device/UbiFit)
+       $(Device/dsa-migration)
        SOC := qcom-ipq8064
        DEVICE_VENDOR := ASRock
        DEVICE_MODEL := G10
@@ -107,6 +120,7 @@ TARGET_DEVICES += asrock_g10
 
 define Device/buffalo_wxr-2533dhp
        $(call Device/LegacyImage)
+       $(Device/dsa-migration)
        SOC := qcom-ipq8064
        DEVICE_VENDOR := Buffalo
        DEVICE_MODEL := WXR-2533DHP
@@ -123,6 +137,7 @@ TARGET_DEVICES += buffalo_wxr-2533dhp
 define Device/compex_wpq864
        $(call Device/FitImage)
        $(call Device/UbiFit)
+       $(Device/dsa-migration)
        DEVICE_VENDOR := Compex
        DEVICE_MODEL := WPQ864
        BLOCKSIZE := 128k
@@ -148,6 +163,7 @@ TARGET_DEVICES += edgecore_ecw5410
 define Device/linksys_ea7500-v1
        $(call Device/LegacyImage)
        $(Device/kernel-size-migration)
+       $(Device/dsa-migration-from-2_0)
        DEVICE_VENDOR := Linksys
        DEVICE_MODEL := EA7500
        DEVICE_VARIANT := v1
@@ -168,6 +184,7 @@ TARGET_DEVICES += linksys_ea7500-v1
 define Device/linksys_ea8500
        $(call Device/LegacyImage)
        $(Device/kernel-size-migration)
+       $(Device/dsa-migration-from-2_0)
        DEVICE_VENDOR := Linksys
        DEVICE_MODEL := EA8500
        SOC := qcom-ipq8064
@@ -223,6 +240,7 @@ TARGET_DEVICES += meraki_mr52
 
 define Device/nec_wg2600hp
        $(call Device/LegacyImage)
+       $(Device/dsa-migration)
        DEVICE_VENDOR := NEC
        DEVICE_MODEL := Aterm WG2600HP
        SOC := qcom-ipq8064
@@ -236,6 +254,7 @@ TARGET_DEVICES += nec_wg2600hp
 
 define Device/nec_wg2600hp3
        $(call Device/LegacyImage)
+       $(Device/dsa-migration)
        DEVICE_VENDOR := NEC Platforms
        DEVICE_MODEL := Aterm WG2600HP3
        SOC := qcom-ipq8062
@@ -252,6 +271,7 @@ TARGET_DEVICES += nec_wg2600hp3
 
 define Device/netgear_d7800
        $(call Device/DniImage)
+       $(Device/dsa-migration)
        DEVICE_VENDOR := NETGEAR
        DEVICE_MODEL := Nighthawk X4 D7800
        SOC := qcom-ipq8064
@@ -271,6 +291,7 @@ TARGET_DEVICES += netgear_d7800
 
 define Device/netgear_r7500
        $(call Device/DniImage)
+       $(Device/dsa-migration)
        DEVICE_VENDOR := NETGEAR
        DEVICE_MODEL := Nighthawk X4 R7500
        DEVICE_VARIANT := v1
@@ -288,6 +309,7 @@ TARGET_DEVICES += netgear_r7500
 
 define Device/netgear_r7500v2
        $(call Device/DniImage)
+       $(Device/dsa-migration)
        DEVICE_VENDOR := NETGEAR
        DEVICE_MODEL := Nighthawk X4 R7500
        DEVICE_VARIANT := v2
@@ -306,6 +328,7 @@ TARGET_DEVICES += netgear_r7500v2
 
 define Device/netgear_r7800
        $(call Device/DniImage)
+       $(Device/dsa-migration)
        DEVICE_VENDOR := NETGEAR
        DEVICE_MODEL := Nighthawk X4S R7800
        SOC := qcom-ipq8065
@@ -322,6 +345,7 @@ TARGET_DEVICES += netgear_r7800
 
 define Device/netgear_xr450
        $(call Device/DniImage)
+       $(Device/dsa-migration)
        DEVICE_VENDOR := NETGEAR
        DEVICE_MODEL := Nighthawk XR450
        SOC := qcom-ipq8065
@@ -336,6 +360,7 @@ TARGET_DEVICES += netgear_xr450
 
 define Device/netgear_xr500
        $(call Device/DniImage)
+       $(Device/dsa-migration)
        DEVICE_VENDOR := NETGEAR
        DEVICE_MODEL := Nighthawk XR500
        SOC := qcom-ipq8065
@@ -351,6 +376,7 @@ TARGET_DEVICES += netgear_xr500
 define Device/nokia_ac400i
        $(call Device/FitImage)
        $(call Device/UbiFit)
+       $(Device/dsa-migration)
        DEVICE_VENDOR := Nokia
        DEVICE_MODEL := AC400i
        SOC := qcom-ipq8065
@@ -365,6 +391,7 @@ TARGET_DEVICES += nokia_ac400i
 define Device/qcom_ipq8064-ap148
        $(call Device/FitImage)
        $(call Device/UbiFit)
+       $(Device/dsa-migration)
        DEVICE_VENDOR := Qualcomm
        DEVICE_MODEL := AP148
        DEVICE_VARIANT := standard
@@ -382,6 +409,7 @@ TARGET_DEVICES += qcom_ipq8064-ap148
 define Device/qcom_ipq8064-ap148-legacy
        $(call Device/LegacyImage)
        $(call Device/UbiFit)
+       $(Device/dsa-migration)
        DEVICE_VENDOR := Qualcomm
        DEVICE_MODEL := AP148
        DEVICE_VARIANT := legacy
@@ -398,6 +426,7 @@ TARGET_DEVICES += qcom_ipq8064-ap148-legacy
 define Device/qcom_ipq8064-ap161
        $(call Device/FitImage)
        $(call Device/UbiFit)
+       $(Device/dsa-migration)
        DEVICE_VENDOR := Qualcomm
        DEVICE_MODEL := AP161
        SOC := qcom-ipq8064
@@ -412,6 +441,7 @@ TARGET_DEVICES += qcom_ipq8064-ap161
 
 define Device/qcom_ipq8064-db149
        $(call Device/FitImage)
+       $(Device/dsa-migration)
        DEVICE_VENDOR := Qualcomm
        DEVICE_MODEL := DB149
        SOC := qcom-ipq8064
@@ -424,6 +454,7 @@ TARGET_DEVICES += qcom_ipq8064-db149
 
 define Device/tplink_ad7200
        $(call Device/TpSafeImage)
+       $(Device/dsa-migration)
        DEVICE_VENDOR := TP-Link
        DEVICE_MODEL := AD7200
        DEVICE_VARIANT := v1/v2
@@ -440,6 +471,7 @@ TARGET_DEVICES += tplink_ad7200
 
 define Device/tplink_c2600
        $(call Device/TpSafeImage)
+       $(Device/dsa-migration)
        DEVICE_VENDOR := TP-Link
        DEVICE_MODEL := Archer C2600
        DEVICE_VARIANT := v1
@@ -454,6 +486,7 @@ endef
 TARGET_DEVICES += tplink_c2600
 
 define Device/tplink_vr2600v
+       $(Device/dsa-migration)
        DEVICE_VENDOR := TP-Link
        DEVICE_MODEL := Archer VR2600v
        DEVICE_VARIANT := v1
@@ -486,6 +519,7 @@ endef
 TARGET_DEVICES += ubnt_unifi-ac-hd
 
 define Device/zyxel_nbg6817
+       $(Device/dsa-migration)
        DEVICE_VENDOR := ZyXEL
        DEVICE_MODEL := NBG6817
        SOC := qcom-ipq8065