ipq806x: chromium: Enable kmod-ramoops by default
[openwrt/openwrt.git] / target / linux / ipq806x / image / chromium.mk
index f908472419d1ce24c86cf2e3f14e18e5bf8cb6c0..ba989299760ea53fa2d774bd2e1792a431af6ed4 100644 (file)
@@ -35,10 +35,14 @@ define Device/OnhubImage
        IMAGES := factory.bin sysupgrade.bin
        IMAGE/factory.bin := cros-gpt | append-kernel-part | append-rootfs
        IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+       # Note: Chromium/Depthcharge-based bootloaders insert a reserved-memory
+       # ramoops node into the Device Tree automatically, so we can use
+       # kmod-ramoops.
        DEVICE_PACKAGES := ath10k-firmware-qca988x-ct e2fsprogs kmod-fs-ext4 losetup \
                           partx-utils mkf2fs kmod-fs-f2fs \
                           ucode kmod-google-firmware kmod-tpm-i2c-infineon \
-                          kmod-sound-soc-ipq8064-storm kmod-usb-storage
+                          kmod-sound-soc-ipq8064-storm kmod-usb-storage \
+                          kmod-ramoops
 endef
 
 define Device/asus_onhub