brcm63xx: Add DT support for HG553
[openwrt/openwrt.git] / target / linux / brcm63xx / profiles / huawei.mk
index 1014884143e8459098c8788154aa66b2e08bf720..594389ec0e151be5baeb8c016fbfff0ccc7e2e72 100644 (file)
@@ -14,6 +14,16 @@ define Profile/HG520v/Description
 endef
 $(eval $(call Profile,HG520v))
 
+define Profile/HG553
+  NAME:=Huawei EchoLife HG553
+  PACKAGES:=kmod-b43 wpad-mini \
+       kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev
+endef
+define Profile/HG553/Description
+  Package set optimized for Huawei HG553.
+endef
+$(eval $(call Profile,HG553))
+
 define Profile/HG556a_AB
   NAME:=Huawei EchoLife HG556a (version A/B - Atheros)
   PACKAGES:=kmod-ath9k wpad-mini \