brcm63xx: Add Comtrend AR-5315u support
[openwrt/openwrt.git] / target / linux / brcm63xx / image / bcm63xx.mk
index dd1ad86501c200d8094aaabf5310f31cbd84da78..6ad15a25e7b9e60f6bd7e270760bddffab01f7bf 100644 (file)
@@ -357,6 +357,19 @@ endef
 TARGET_DEVICES += BTV2500V
 
 ### Comtrend ###
+define Device/AR5315u
+  $(Device/bcm63xx)
+  IMAGES += sysupgrade.bin
+  DEVICE_TITLE := Comtrend AR-5315u
+  DEVICE_DTS := ar-5315u
+  CFE_BOARD_ID := 96318A-1441N1
+  CFE_CHIP_ID := 6318
+  FLASH_MB := 16
+  DEVICE_PACKAGES := \
+    $(B43_PACKAGES) $(USB2_PACKAGES)
+endef
+TARGET_DEVICES += AR5315u
+
 define Device/AR5381u
   $(Device/bcm63xx)
   IMAGES += sysupgrade.bin