brcm63xx: use more systematic names for image and DTS files
[openwrt/openwrt.git] / target / linux / brcm63xx / image / Makefile
index 1cf64bd8e706bf040fde7621439c871c2f4dbbbc..cc1660aa25ba9137d7e9adc2347acc1283264a66 100644 (file)
@@ -161,6 +161,8 @@ define Device/Default
   KERNEL_DEPENDS = $$(wildcard ../dts/$$(DEVICE_DTS).dts)
   KERNEL_INITRAMFS_SUFFIX := .elf
   DEVICE_DTS_DIR := ../dts
+  SOC = bcm$$(CFE_CHIP_ID)
+  DEVICE_DTS = $$(SOC)-$(subst _,-,$(1))
 endef
 
 ATH5K_PACKAGES := kmod-ath5k wpad-basic